RAYA manual

메뉴 상세 설명

   -
기본적인 조작법
   - 파일 종류
   - Global Work
   -
TOPBAR
   - 카메라 작업
   - MaterialWork
   - Object Work
   -
Grass Work
   -
World Work
   -
Terrain World Work
   -
TOPVIEW Work
   -
AVATAR Work
   -
FILTER Work
   - ANI Work
   -
Dummy Work

 작업 과정

   - 에니메이션 메니저 파일 구성
   - 더미 오브젝트 시뮬레이션
   - 지형 작업
   - 알파 특수효과 작업
   - World 에 등록되는 오브젝트를 TerrainWorld와 어떻게 위치를 맞출수 있는가

 FAQ

   - 맵핑 파일
   - 최종 배포본 파일 구성
   - 에니메이션 파일 ( *.dba.*.dbp ) 에 본이나 추가 모델이 삽입 돼었을 때
   - 실행인자
   -
델이 제대로 보이지 않을때
 

메뉴 상세 설명
 

기본적인 조작법


CXCamera 참조
HGUI
참조
 

파일 종류



 

 

Global Work


수평 패닝 마우스 휠 드래그로 조정
카메라 회전 마우스 오른쪽 버튼 드래그
카메라 확대
축소 마우스 휠 조정
LSHIFT 1/10 확대 배율 조정
LCONTROL 10배 확대 배율 조정
LALT 100배 확대 배율 조정
LALT + LCONTROL 1000배 배율 확대 조정  

키보드 설정
Ctrl + ~   열려진 메뉴 초기화
X   물체 시야 근접 확대
TAB   전체 화면 모드

퀘이크 FPS 이동 모드 휠마우스로 최대한 CAMARROW 에 접근시켜서 키보드로 이동하면 1인친 시점 카메라 모드가 됩니다.

회전 중심 물체에 맞추는법,목표지점 타겟팅 오른쪽 마우스 버튼 더블클릭하면 그 지점으로 CAMARROW 가 자동으로 이동하여 카메라가 그 지점을 중심으로 회전합니다.
정밀 조정
목표 물체에 녹색 화살표가 파묻힐때까지 휠드래그와 W,S,R,F 키로 조정

모델 로드 하는법
Object 메뉴-> LoadModel 혹은 *.db3 파일 화면에 드래그
LCTRL키를 누른 상태에서 파일을 드래그 하면 덮어쓰기 여부를 물어보지 않는다
 

TOPBAR


FILE  최근 파일들을 유지합니다. 클릭하면 그 파일을 로드합니다.

World,Terrain,Model,Grass,AVATAR  <- 해당 객체들을 보여줄것인가 여부 설정

Model,Grass,Avatar,Tedit,World  <- 현재 어떤 작업을 할것인가 지정

BBOX  선택된 오브젝트의 바운딩 박스를 보여줄것인가.

30 fps  30 프레임 고정, TAB 키로 풀화면시 자동 해제!

WORLD  회전자로 작업할 때 WORLD 축을 중심으로 회전할것인가. 단축키 키보드 1번
LOCAL  회전자로 작업할 때 LOCAL 축을 중심으로 회전할것인가. 단축키 키보드 2번

PICK  회전자,무브 작업이 아닌 일반 셀랙트 작업. 단축키 키보드 3번
MOVE  무브 작업. 단축키 키보드 4번  
GRASS 작업시 왼쪽 쉬프트 키를 누르고 MOVE 하게 되면 3dsmax 처럼 복사 됩니다.

ROTATE  회전
작업. 단축키 키보드 5번

SCALE  오브젝트의 스케일을 변경할 수 있습니다.단축키 키보드 6번
ZoomExtend  물체 시야 근접 확대

카메라 작업


- FILE


LoadMODE   카메라 셋팅 로드
SaveMODE   카메라 셋팅 저장
ResetPos
  원점으로 타겟 카메라 위치 초기화,현재 위치가 알수 없을때 사용
LoadPOS   카메라 위치 부르기
SavePOS
  현재 카메라 위치 저장

- NAVIGATE

NAVIGATE   키보드,마우스 이동 모드  CXCamera 참조
AVATAR  캐릭터 시뮬레이션시 아바타 카메라 모드로 작동 AUTO  캐릭터 네비게이트시 캐릭터 뒤를 항상 향합니다.
ANIPATH
  카메라 이동 에니메이션 패스 지정 모드 ( Set 버튼으로 에니메이션 패스 파일 지정 )
DEG,ANG   이동 ,회전 속도 조절. 키보드 이동시

- OPT

BGRID
  화면에 월드용 블록 표시
PLANE,GRID   화면에 그리드 표시 지정
COORD  좌측 상단에 좌표계 표시
SUN
 좌측 상단 좌표계에 태양 위치 표시

CAMARROW  회전 타겟 지점 표시,녹색 삼각기둥 ( 이 삼각기둥을 중심으로 카메라가 회전합니다 )

STENCIL
  스텐실 볼륨 그림자 표시여부

ARROW  Picking 지점 표시,적색 삼각기둥 ( 현재 마우스로 타겟팅 된 지점 표시 )

- Color


BK 
Fog 칼라 지정
L_A  Ambinet, 그림자쪽 칼라 지정.
L_ Diffuse 빛받는쪽 칼라 지정
L_S 
Specular, 스펙큘러 칼라 지정.
G_A 
Global ambient 칼라 지정

ALL  회색톤
모드로 지정

- 빛 방향 지정

Phi,Theta  : 구좌표계 모드로 빛의 방향 설정, 왼쪽 상단에 빛의 방향 노란색 삼각뿔로 표시

-  Filter

min POINT,LINEAR   근거리 필터 해제,설정
mag POINT,LINEAR   원거리 필터 해제,설정

- FOG

ENABLE   안개 여부 설정
FOG_NONE   안개 비 활성화
FOG_LINEAR
  LINEAR 모드 안개 설정( 선형 )
FOG_EXP   EXP 모드 안개 설정
FOG_EXP2
  EXP2 모드 안개 설정

Denti   EXP 모드 안개일때 안개의 강도 지정
FogRange
  LINEAR 모드 일때 안개의 범위 지정

- SKY

SkyBOX   스카이 박스 모델을 지정합니다.
SUN        
태양 모델을 지정합니다.
참고 파일 skybox.zip

 

Material Work


- Color

참고 디렉토리 SDK/data/3d/variousmodel/mat1.db3

Diffuse  A
값은 ALPHA 로 의미가 있습니다. ALPHA 가 적용되면 렌더링 제일 후순위로 밀리게 됩니다.

Ambient
Emissive
Specular
ALL
R,G,B 동일하게 GRAY 색상으로 적용시킨다.


Reinit
텍스춰가 있는 머터리얼일 경우 Diffuse를 최고로, 맥스에서 바로 불러온 데이터라면 초기에한번 해준다.
ChangeTEX  
현재 지정된 텍스춰를 다른 텍스춰파일로 변경.
OpenTEX  DirectX 퉅인 DxTex를 열어준다. 덱스춰 포맷 변경시 작업 편리.

- 속성

NonVisual   Visual 셋팅 지정
MaxEmissive   자체 발광 최대, 주로 특수효과에 사용, 빛의 영향을 무시할 때
NoFilter   Filter 지정
TwoFace
  양면 다 보이게 처리

Specular  스페큘러 지정
POWER
  스페큘러 반사값 조절

ForceLocal  참고 디렉토리 SDK/data/3d/variousmodel/tree.db3
해당 머터리얼을 가진 면이 항상 날 쳐다보게 합니다. 델타는 회전중심점을 시야쪽으로 확대합니다.
( 가로등에서 Glow 머터리얼이 가로등 봉에 가려지는 경우를 막기 위해 )

ColorKey 참고 디렉토리 SDK/data/3d/vvariousmodel/weed_a_012.db3
핑크색 칼라는 투명이 됩니다.
BOUND   DDS 투명도 경계값 지정

알파 속성 지정 참고 디렉토리 SDK/data/3d/vvariousmodel/2face1.db3
알파 계산식 참조

 

Object Work


오브젝트 순서는 알파벳순으로 자동으로 정렬됩니다.

SelSUPER  SubModel 이 아닌 SuperModel 속성을 지정하기 위한 작업 선택
Save
 모델을 저장하기 전에 Modify 여부 확인할것!

- 속성
ForceTransform

Cartoon : 외곽선 굵기 조절 가능

- Transform

Modify   이동 ,회전 변환후 실제로 모델을 변경하고자 할 때, Save 하기전에 반드시 적용해야 합니다.
Identidy  이동,회전 변환을 취소합니다.

MovePivotCenter 오브젝트의 중심을 월드의 중심점으로 옮깁니다. 반영할려면 Modify 를 반드시 누르세요
 

Grass Work


그래스란 심을수 있는 모든 객체를 말합니다. *.spk,*.cfx 같른 특수효과 파일도 등록이 됩니다.

LoadTXT   그래스 파일을 엽니다 *.blg
SaveTXT   
그래스 파일 저장 *.blg
LoadBIN    
그래스 이진 파일을 연다. blg파일의 배포본 파일 blb 파일 로드
SaveBIN    
그래스 이진 파일 저장

Scale   해당 종류의 Grass 의 스케일을 조정합니다.

AddGrass
  월드에 심을 오브젝트를 등록합니다.

StaticModel(*.db3)
AniModel(*.ani
,*.anp)
ParticleFX ( *.cfx ) - 파티클도 심을수 있습니다
.


AddLod     해당 그래스의 LOD모델을 서브로 등록합니다.

DelGrass    그래스 파일 삭제. 현재 작업된 파일들도 전부 지워진다.

DelLod    해당 그래스의 LOD 서브 모델 삭제

UnDo    가장 마지막에 삭제된 그래스 파일 하나 복구

LoadModel    현재 선택된 그래스를 RAYA의 오브젝트로 로딩시킵니다.

Delete   현재 심어진 그래스 개체 하나만 지웁니다.

작업 모드 ( 항상 Select Mode 버턴을 살펴 보세요! )

LoadGrass를 하고 난 후에는 기본적으로 셀렉터모드
Select Model 가 비활성화 이면 심는
모드  
Ctrl를 키를 누르고 있는 동안은 셀렉트 모드로 강제 전환.

RandomPos   글래스를 심을 때 회전성분을 렌덤값으로 취합니다
LastTrans  이전에 적용된 회전성분을 그대로 가져온다.
PREV,NEXT   작업전후의 그래스를 선택할 수 있습니다.

 

GRASS 작업시 왼쪽 쉬프트 키를 누르고
MOVE 하게 되면 3dsmax 처럼 복사 됩니다.

 

World Work

 
Create
월드 생성
AddModel 에 등록하면 Octree World 구조로 관리됩니다.  
AddModel
에서 anp,ani 파일같은 에니메이션 파일도 등록할 수 있습니다!

Save *.bl3 파일로 저장.

옥트리 월드 구조는 맥스생성시 위치 그대로를 가져 온다. 위치 변경이 필요할시 오브젝트에서 위치 변경 작업을 해서 SaveModel *.db3를 AddModel 하면됩니다.

참고  렌더링 순서 정책

Terrain World Work

 
Create   월드 생성, 파란색 해수면 가이드  나온다.
LoadTWorld 월드에 관련된 모든 파일들이 로드됩니다.
SaveTWorld  월드에
관련된 모든파일들이 저장됩니다.

*.ter   -> 지형 전체 파일
*.map ->
높이 파일(엔진에서 사용)
*.mnr  ->
노말벡터 파일(엔진에서 사용)
*.oct   ->
충돌용 파일(엔진에서 사용)
*.zeq  ->
충돌용 파일(엔진에서 사용)
*.raw  ->
해당 레이어의 투명도 마스크 파일 ( 포토샵에서 편집 가능 )

- 반드시
Global detail 텍스춰 와 높이맵이 지정되어 있어야 저장이 가능합니다.


LoadRawH,SaveRawH  지형 높이 파일을 *.raw 로 로드,저장합니다. 포토샵에서 편집 가능

 
LoadHeightPNG   1025 x 1025 크기의 높이맵을 로드합니다.
BuildGEO   현재 편집중의 지형은 조명 쉐이딩이 실시간으로 반영되지 않는다. 이버튼을 누르면 조명 쉐이딩이 전부 새로이 갱신됩니다.

Smooth   Edit 의 Smooth와 동일하지만 전체 지형을 일괄적으로 적용합니다.
CreateHeight
  Opacity의 높이를 참조로 지형을 생성합니다.

LoadHeightPoly  맥스에서 작업된 폴리곤 파일을 높이정보로 가져온다. 기존의 정점을 로드된 정점의 높이로 치환해 버린다. 로드하는 맥스 폴리곤 파일은 지형엔진의 격자와 동일한 격자 좌표를 가져야 합니다. 좌표가 틀리면 치환해야할 정점을 찾을수가 없다. terrain_mesh.max  (9.0) ) 파일을 참조

 
-  
terrain_mesh.max 형식의 전체 크기의 파일을 가져오는게 아니라 부분크기만도 가능하다.
 
- Show

LOD :
LOD여부 설정, LOD 레벨 배수 지정
HeightColor :  높이맵을 편하게 볼수 있게 합니다. 지형 높이 작업시 이 모드 추천.

- Layer

현재 작업 레이어 지정 Layer1 레이어 Show On/Off 지정
1-6 번까지는 디테일 텍스춰 레이어로
사용되고  7-10 번까지는 풀 전용 레이어
1-6 번까지는
SetLayer 로 텍스춰 지정, 7-10 번까지는 SetGrass 로 풀 텍스춰 지정

BoundKey 7-10번까지의 Grass 텍스춰의 투명도 경계값지정
Tile : 타일링 배수를 조절합니다.

ReLoad : 텍스춰가 외부에서 수정되었으면 다시 불러들인다.
LoadMask : 해당 레이어의 투명도 마스크값은 *.raw 파일로 포토샵에서 불러들일수 있습니다.
포토샵에서 수정한 마스크 값을 다시 불러들일때 사용. *.raw 파일은 레이어에 텍스춰가 지정
되어 있을 때 생성됩니다.
 

포토샵에서 *.raw 파일 불러들일때 옵션


Guide :
해수면 가이드 높이값 지정

- Global Detail

LoadGlobalDetail : 최초 배경이 되는 타일링 텍스춰 지정, 레이어 0번
TilingMUL : 타일링 배수를 조절합니다.
Clear : 레이어 0번 텍스춰 해제

- EDIT

작업 모드 지정

GeoEdit  지형
고저 편집 작업,SHIFT 키를 누르면  Smooth 처리됩니다. Reverse  지형을 반대로 밑으로 내린다.

- 지형 편집 환경 지정법
-
1. HeightColor 버튼을 켜면 쉽제 지형을 편집할 수 있습니다. Gray는 엘레베이션 칼라를 그레이 색상으로 지정.

2. (비추천) Camera->World 에서 7X7 블록 렌더링 모드로 셋팅한후 Terrain 메뉴 -> Show에서 Wire를 체크합니다. 그리고 Terrain메뉴 -> ShowETC LOD를 꺼준다.

지형이 변경되었으면 라이트 쉐이딩을 확인하기 위해 반드시 BuildGEO 버튼을 한번 눌러준다.

Erase  레이어를 지우거나 지형을 반대로 내릴때 사용. ALT 키를 누른것과 같습니다.
Normal  현재 Opacity 값으로 레이어 페인팅 합니다.
Add 배경에 칠해져 있는 Opacity값과 더해서 레이어 페인팅 합니다.
Over 기존의 칠해진 Opacity값을 무시하고 레이어 페인팅 합니다.

ABSHeight  오른쪽 옆 카운터에 지정된 높이값으로 평지로 맞춘다. 넓은 평야 만들때 사용
CenHeight  현재 클릭된 높이로 지형을 평탄화 작업
Smooth
 지형 스무싱 처리 , SHIFT 키를 누른채 GeoEdit 해도 됩니다.
LPaint
 레이어 페인팅 작업 지정

HeightMUL 현재 지형 높이에 지정된 수를 곱합니다. 지형의 고저차를 벌릴때 사용, 수치입력하고 버튼 누르면 동작
HeightADD
현재 지형 높이에 지정된 수를 더합니다. 지형를 전체적으로 고도를 조절할 때 사용,수치입력하고 버튼 누르면 동작

- BRUSH

Radius 브러쉬의 반지름 지정, 단축키 BRACKET 키
Opacity 브러쉬의 강도 지정, 화면에 빨간 사각형의 투명도를 보며 조절할것 단축키 SEMICOLON,APOSTROPHE
Hard
 브러쉬의 중심 진하기 설정, 브러쉬의 투명도 곡선 조절, 값을 높이면 완만한 경계가 사라집니다.
단축키
PERIOD,SLASH

- 지형 편집에서 ALT 키를 누르고 작업하면 -로 내려갑니다.
-
지형 레이어 페인팅에서 ALT 키를 누르고 작업하면 지워진다.

- 지형 매쉬 파일 구성은 32x32 짜리 사각형을 32x32 개 가진 하나의 블록을 전체 월드가 32x32 블록으로 가진다.

- 참고 맥스
파일 (  terrain_mesh.max (9.0) )
- 가상 경계 블록 맥스 파일 (  
block_grid.max (9.0) )

- 지형 레이어 텍스춰는 왠만하면 256 크기의 밉맵을 가진 dds 파일로 만드는게 보기 좋습니다.

- 기본 지형을 2X ( 가로세로2배 확장 ) 월드로 변환법

1. 기존의 지형파일을 연다.->SaveRawH 로 높이맵 저장

2. NewTWorld ->Create2X 로 지형 생성

3. 포토샵작업 ( 저장해둔 높이맵 로드 ( 1024x1024 1channer 16비트 IBM PC ) ->2048x2048 으로 Resize -> Blur 처리 -> Save raw file( IBM PC) )

4. LoadRawH 로 리사이즈 된 높이맵 로드. ( 다이얼로그 박스에스 ~heightmap.rat 이후 ~heightmap.raw 파일지정 해서 로드)

5. DetailMAP,Layer 텍스춰 재 할당 -> ter 파일 내용 참고해서 tiling 배수 재 조절
또는 ter 파일을 텍스춰 편집기로 열어서 문자열 복사 편집해도 됨

6. LoadMask 마스크 맵 재 로드( 사이즈 변화 없음 )

7. 다시 저장.

8. ter 파일 참고해서 필요 없는 *.raw 파일 지우기

 

TOPVIEW Work

 
더블 클릭하게 되면 해당 위치로 이동합니다.
마우스 드래그 하면 패닝 할 수 있습니다.

AVATAR Work


Load
  RAYA에 기본으로 지정되어 있는 캐릭터 데이터 로드
DoTeleport  현재
마우스로 타겟팅 된 지점 으로 강제 이동합니다.
Jump 위로 약간 점프 시킨다.

LoadCFG  현재
아바타 셋팅을 로드합니다.
SaveCFG  현재 아바타 셋팅을 저장합니다.

LoadPOS  현재 아바타 위치를 로드합니다.
SavePOS 현재 아바타 위치를 저장합니다.


LoadFILE  기본 지정된 아바타가 아니라 유저가 캐릭터를 로드할 수 있습니다. 충돌구용 모델도 지정해줘야 합니다.

Scale  아바타의 초기 스케일을 조절할 수 있습니다.
Graviry  아바타의 중력을 지정할 수 있습니다.
SHeight  카메라가 캐릭터의 어디 높이를 쳐다볼 것인지 지정할 수 있습니다.
Ground 중력적용에서 최저 한계 높이를 지정합니다. 더 이상 내려가지 않는 높이
MoveDEG
어느정도 이동할것인가 지정.

Cartoon  외곽선 처리 여부 지정

아바타 이동중에 ESC를 누르면 이동을 멈춘다.

FILTER Work


- 텍스춰 칼라 변경 -

ORITEX :
라이트맵에 백그라운드 원래 텍스춰
LIGHTMAP :
원래의 텍스춰에 입혀져있는 조명맵
NORMALMAP :
조명맵이 없는 단순 맵

머터리얼 칼라가 아니라 텍스춰 자체 픽셀의 칼라를 변경합니다. 레디오시티 결과물이 맘에 들지 않을 때 여기서 텍스춰 칼라를 변경해봅니다. R,G,B 다음 칼라는 Contrast 입니다. 명함비를 조절할 수 있습니다.

 

ANI Work


    - Animation -

    Deg
     왼쪽 브라우저 해당 에니메이션의 프레임 보간 간격을 지정합니다. 1이 기본.

    에니메이션 파일 메모리 용량을 줄이기 위해서도 사용하기도 합니다.
    보통 맥스에서 100프레임 짜리 에니메이션이 있습니다면 출력할때는 1/4 로 줄여서 25 프레임으로 출력합니다.
    그리고 Deg에서 0.25 를 적으면 4배 늦게 에니메이션이 되기 때문에 실지로 전체 프레임이 4배로 확장된 효과가 있습니다. 그래서 에니메이션 속도는 100프레임 짜리와 동일합니다. 보통 4배로 줄여서 맥스에서 출력해도 원본과 큰 차이는 없습니다. 모션이 아주 복잡하다면 2배정도로 낮추어 줄 필요가 있습니다. 

    Frame
     현재 진행되고 있는 프레임 값 출력

    ANI TYPE
    에니메이션 진행 타입 지정
    SIGN
      에니메이션 진행 방향 지정

    AddRAB  *.rab 에니메이션 파일을 등록합니다.

    - Bone -

    Active 해당 본의 활성화 여부 지정. SaveModel시 파일에 Active 여부가 기록됩니다. 상하체 분리시 유용.

DUMMY Work

     

    GetPivot  현재 ObjectMenu에 선택되어져 있는 피봇 모델에 지금 오브젝트를 붙인다.
    DeletePivot  피봇 모델 초기화
    Clear  현재 등록되어 있는 더미 모델 초기화
    AddModel  더미 모델 등록
    Scale
     더미에 붙을 때 스케일 값 적용

    FAQ

 

 


작업 과정
 

에니메이션 메니저 파일 구성 ( *.ani  ,*.anp )    참고 디렉토리 RAYA\ample\_ANI\BOX\


Object 메뉴-> LoadModel 플러그인에서 출력된 모델(
*.dba 혹은  *.dbp ) 파일을 로드합니다. 또는 파일을 화면에 드래그 합니다.

Animation 메뉴 -> AddRAB 플러그인에서 출력된 에니메이션 (
*.rab) 파일을 로드합니다. 혹은 화면에*.rab 파일을 드래그 합니다.

Object 메뉴-> SaveModel
*.ani 혹은 *.anp
확장자로 모델과 에니메이션 정보가 있는 메니저 파일을 저장합니다

Object 메뉴->NewModel -> LoadModel 다이얼로그 박스의 확장자 탭을 눌러서 *.ani 로 바꾼후 방금 저장한 파일을 로드해봅니다. 혹은 *.ani 파일을 화면에 드래그 합니다

더미 오브젝트 시뮬레이션    참고 디렉토리 SDK\data\char\pivot_dummy\ 


Object 메뉴 와 DummyModel 메뉴를 엽니다.
Object 메뉴 -> 링크하고자 하는 피봇 모델을 선택해둡니다. 해당 피봇 서브오브젝트에
ForceTrans,NonVisual 옵션을 켭니다.

DummyModel 메뉴 -> AddModel 버튼을 눌러 링크되고자 하는 모델을 불러서 등록합니다.
GetPivot를 누르면 링크 됩니다.
 

지형 작업


TerrainWorld 메뉴를 연다 -> Create -> LoadHeightPNG
( 1025x1025로 24비트 형식의 png 파일)
-> Guide로 해수면 높이 조절 -> LoadGlobalDetail ( 전체 타일로 깔릴 기본 베이스 레이어 지정 )
-> SetLayer 로 해당 레이어 텍스춰 지정

-> GeoEdit 로 지형 높낮이 조절
-> LPaint 로 레이어 페인팅

- Reverse 버튼을 체크하거나 ALT 키를 누르면 GeoEdit는 반대로 지형이 내려가고 LPaint 시는 페인팅이 지워집니다.
 

알파 특수효과 작업    참고 디렉토리  SDK\data\Common\FX\


- 2face_plane.ra1 파일을 RAYA에 드래그 합니다.
- Material Menu를 연다.
- Camera Menu 의 OPT에서 PLANE과 BGRID를 끈다. GRID는 켭니다
- Material Menu 의 상단 브라우저에서 ----alpha---- 두 번째 라인을 선택합니다.
- 오른쪽 Color 의 알파값
( 흑색 슬라이드 )를 조절하면 투명도가 조절됩니다. 255값이면 전혀 투명도가 안먹히므로 250 정도로 셋팅해둡니다.
- 하단 SRCALPHA
,DESTALPHA 속성값을 조절하면
알파 오퍼레이션을 지정할 수 있습니다. 

World 에 등록되는 오브젝트를 TerrainWorld와 어떻게 위치를 맞출수 있는가


- 지형월드를 로드합니다.
- 오브젝트 메뉴로 위치를 수정할 메뉴를 로드합니다. 혹은 화면에 파일을 그냥 드래그 합니다.
- 지형에 맞추어서 Move
,Rotate를 합니다.
- Object Menu에서 Modify 후에 SaveModel을 합니다.
- World Menu를 열어서 AddModel 한후에 SaveModel 하면됩니다.
 

 FAQ

맵핑 파일


- 맵핑 파일 우선권

맵핑파일은 파일네임만 의미가 있고 확장자는 의미가 없습니다.
다음과 같은 파일이 여러개 같이 있는 경우엔 abc.dds 가 로드되고 나머지는 무시됩니다.

abc.dds
( dds가 가장 우선권 )
abc.png
abc.jpg

- dds 파일 사용법 권장.

nvidia.com 의 dds 포토샵 플러그인을 사용.

DXT 계열의 포맷을 사용해야 압축이 지원되어서 맵소스 용량을 충분히 줄일수 있습니다.
DXT1 RGB    알파가 없는 텍스춰 사용.
DXT1 ARGB  투명 처리만 되는 텍스춰 사용. ( 로고 글자 표시 )
DXT3 ARGB  알파는 4비트로 표현. 좀더 스무스한 알파 처리를 할 수 있습니다.( 나뭇잎,머리카락 등 )
DXT5 ARGB  알파는 8비트로 표현. 확실히 스무스한 알파 처리를 할 수 있습니다. ( 특수효과 에 사용 )

렌더링 정책

렌더링 우선수위는 DXT1부터
DXT5  순으로 렌더링 됩니다. 특히 BlockWorld 에서는 이점을 꼭 유념해야 합니다.모든 텍스춰를 DXT5 로 통일하게 되면 알파의 유무에 상관없이 렌더링 우선수위 정책이 사라집니다. 월드에서 알파가 나중에 찍혀야 한다면 알파 채널 유무에 따라 반드시 DXT1(알파채널없음) DXT3,DXT5(알파채널있음)을 반드시 구별해서 써야만 알파가 나중에 찍혀서 어색함이 없습니다.

텍스춰 크기

256x256 이하의 2의 승수(2,4,8,16,32,64,128,256...) 사용 권장
고사양 그래픽카드가 아니라면 보통 월드는 256 크기. 캐릭터는 512 정도가 적합합니다.

그래픽카드에 따라서 2의 승수를 지원하지 않는 카드라면 로드하면서 강제로 2의 승수로 맞추는 과정에서 이미지 왜곡이 발생할수 있습니다. 따라서 2의 승수를 지키는게 좋습니다. 가로 세로는 틀려도 됩니다.
UI작업에서는 이미지 외곡을 방지 하기 위해서 2의 승수로 맵을 만드시고 화면에 표시 되지 않는 여백 부분은 알파로 처리하시면 됩니다.
카메라 메뉴의 Enum 버튼을 눌러보면 NonPOW2 라는 체크버튼이 켜저 있지 않으면 2의 승수를 지원하지 않는 카드입니다.

2의 비승수도 지원하고 256 이상의 크기도 지원하는 NVIDIA 카드 일지라도 속도 저하가 발생됩니다.
부득이한 경우가 아니라면 2의 승수와 256 이하의 텍스춰를 쓰는게 속도가 월등히 빠릅니다.

렌더링 품질

dds의 dxt 압축은 메모리를 아낄수 있는 대신 픽셀이 깨집니다. tga 파일이나 png 파일을 쓰면 원본 그대로를 유지 할수 있습니다. 24비트 tga도 16비트로 로드되기 때문에 32비트 파일로 저장해야 합니다. 압축이 아닌 dds 포맷은 tga 포맷과 동일합니다.

최종 배포본 파일 구성


파일 종류 참고

매니저 파일 ( *.ani , *.anp )
모델 파일 (
*.db3 , *.dba, *,dbp, *.dbl )
에니메이션 파일 (
*.rab )
-> 여기까지의 파일들은 서로 연관성이 있어서 반드시 같이 있어야 하며 한디렉토리에 있어야 합니다.
텍스춰 파일
( *.dds , *.tga , *.png,.... )
 

에니메이션 파일 ( *.dba.*.dbp ) 에 본이나 추가 모델이 삽입 돼었을때


추가모델만 삽입된 경우 에는 dba,dbp 파일만 뽑아주고 에니메이션 파일 *.rab 는 그냥 그대로 유지.
추가 본이나 바이패트가 삽입된 경우 에는 dba,dbp 모델파일도 뽑고 rab 에니메이션도 전부 새로이 뽑아줘야 합니다. rab에는 본정도가 들어가 있으므로 모델파일이 영향을 받을려면 기존에 뽑아둔 rab 는 새로이 다 뽑아주는게 좋습니다.
 

델이 제대로 보이지 않을때


- 알파 채널이 제대로 보이지 않을때. 동영상 참고  ftp://public:public@raysuper.iptime.org:300/raya_material.avi
- 면이 뒤집혀 보일때는 맥스에서 ResetXForm을 제대로 했는지 확인합니다. 그림 참고.

실행인자


P:preload.pos 카메라 위치 초기 설정
파일 지정
L:prelaod.db3 실행시 자동으로 로드되는 데이터 파일 지정
F:1 fast game 모드 설정, 툴 모드가 아닌 실제 게임 모드로 빠른속도로 돌아갑니다. ( 1:true. 0:false )
E:1  full window 모드 설정, false 이면 1024 x 768 윈도우 모드로 돌아갑니다. ( 1:true. 0:false )
W:400 가로 화면 해상도 크기
H:400 세로 화면 해상도 크기

폴리곤 갯수 설정


폴리곤 갯수는 게임의 기획에 따라 많이 틀립니다. 중저사양의 일반 컴뮤니티 게임일 경우 캐릭터는 2000-5000개 사이가 좋고 월드의 나무도 1000-4000개 사이가 좋습니다. 캐릭터나 나무 둘다 LOD 처리가 가능 하므로 폴리곤 갯수가 너무 많을경우 실시간으로 LOD 처리가 가능합니다.

환경 설정

메뉴의 모든 수치 저장은 c:\fltk_cfg\ 에 기록됩니다. 초기치로 돌아가고 싶으면 c:\fltk_cfg\ 디렉토리 통째로 지워주시면 됩니다.